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Introduction to Style Sheets 
 
What are Cascading Style Sheets? 
 
Separate documents within a Web site which contain the descriptions for displaying or printing 
Web documents. When these documents are attached to Web pages, they tell the browsers how 
to layout the Web page. CSS means cascading styles since these documents can contain many 
styles, which “cascade” down the document. 
 
What is the purpose for CSS? 
 
HTML (a derivative of SGML) was designed primarily as a content-based mark up language. 
The past few years have seen the introduction of many new Physical Formatting and other 
elements/attributes by browser vendors which has muddied the intention of HTML. One of the 
main reasons for Style Sheets is to stop the creation of new HTML Physical Formatting elements 
(like FONT) by browser vendors that specify style information. The means the separation of 
document structure from the document's layout. 
 
 
Advantages of Style Sheets  

• Increases download speed (using CSS syntax instead of images or sound files)  
• Designs become easier to manage through the elimination of inline tags such as <font> - 

as well as the benefit of site-wide changes through the use of external style sheets 
• Pages render more quickly (when using CSS-P) through the elimination of nested <table> 

tags (P stands for positioning) 
• Pages become more accessible (Section 508) to visitors using assistive technologies 
• Properties are specified using common desktop publishing terminology  
• Easy to author and read  
• Produces nicer HTML markup that is more flexible and maintainable  
• Easy transition from HTML extensions  
• Many new visual control features  
• Easy extension for future capabilities 

 
CSS and Style 
 
CSS governs the separation of style (or presentation) from actual content. This means that CSS 
can define the style of much of the content in Web pages. 
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CSS is a W3C (World Wide Web Consortium) standard.  
 
The World Wide Web Consortium develops specifications, guidelines, software, and tools so 
that the Web can be used to its full potential. 
 

• CSS 1 was ratified for use in December 1996 
o CSS 1 Contains properties for fonts margins, colors, etc. that nearly all profiles of 

CSS need 
• CSS 2 came out in 2000 with a addition of image location in a document. 

 
 
Why didn’t we use CSS before? 
 
CSS suffered from slow adoption  
 

• Limited browser support 
• Limited tools for development 

 
 
Today all major browsers support CSS 
 
Implementation still varies-but the differences are relatively slight and they are getting better. 
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The Rational 
 
Okay, so why do we need CSS? 
 
HTML is limited in its design capabilities. This is because HTML was designed to “mark up” or 
in layman’s terms, identify content, not to create complex designs used in Web pages today. 
Once designers learned that they could take HTML tags that were designed to identify content 
and use those as design tools, they lost the ability to modify the presentation of the mark up 
easily. The problem is that by doing this you end up with using tags repeatedly throughout a Web 
page to define styles of different elements in the page. An example would be the font tag.  
 
 
Font Tags 
 
A typical font tag found in a document defines the attributes of a given set of text:  
 
<font ="Arial, Helvetica, sans-serif" color="#990000" size="+1"> 
 
Font tags such as the one above can be found throughout 95% Web pages today.  They add to 
length and complexity of the code and time needed when revisions are needed. 
 
Other culprits are the table tags and body tags. 
 
 
DIV Tags  
 
The key to successfully designing with CSS is to DIVide it up! (using <DIV> tags) 
 
The <div> tag is used to define page elements or “containers” – although all HTML tags are 
actually containers as well. 
 
If it is helpful for you, you can think of a <div> as a table cell that doesn’t have a table! 
 
By default, only a single <div> tag can exist on any horizontal band, or line. The float attribute 
removes the <div> tag from the flow of the document and allows other elements to flow around 
the <div>. 
 
Elements such as the <div> tag, can also be positioned using the position attribute. There are 
four options for position: absolute, relative, fixed, static. 
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Where does CSS come in? 
 
How will CSS help? 
 
CSS replaces the presentational markup in HTML documents. Presentational markup refers to 
the way a browsing device displays a piece of content. 
 
Revising and Updating 
 
Revising and updating pages with new styles will require much less time and labor. Changing the 
style in one location will update the all applied areas including the entire site! 
 
Going Table-less 
 
For a completely table-less design, or CSS-P design, all of the presentational HTML tags should 
be removed from the page: 
 

• <table>, <td>, <tr>, <th> 
o These tags will be replaced through the use of the <div>  tag, with either a class 

or an ID assigned to the <div> 
 

• <font>  
o Text styling will be done through the use of either a tag definition, class or ID 

 
• Presentational attributes such as cell padding, alignment, color and backgrounds. These 

attributes become part of the tag definition, class or ID 
 
 
Possible problems?  
 
Older browsers do not recognize some CSS styles. 
 
 
Check Browser Support 
Since there are problems with using CSS for users till holding on their older browsers, in 
Dreamweaver you can select the result panel and see the problems and browsers that will have 
problems. 
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Demonstration of CSS in action 
 
The following URL will take you to a video created by the developers at Macromedia that 
will walk you through using CSS: 
http://www.macromedia.com/cfusion/ondemand/index.cfm?id=242&type=2 
 
A great resource for Learning CSS: 
Macromedia Dreamweaver Developer Center: CSS in Dreamweaver MX 2004 
http://www.macromedia.com/devnet/mx/dreamweaver/css.html 
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Using CSS in HTML Documents 
 
There are three ways to use CSS in HTML. 
 
 

• Inline styles – styles found in the body of the HTML document as they are applied. 
Frowned on. 

 
<div id=”housepicture” style = “position: fixed; right: 300 
px; top: 200px; width: 240px; height:240px z-index:1”> 

 
• Local – style definitions contained in the head section of an HTML document. 

 
<HEAD> 
<TITLE>Info and Updates</TITLE> 
<style type="text/css"> 
<!-- 
body { 
font-family: Arial, Helvetica, sans-serif; 
} 
--> 
</style> 
</HEAD> 

 
• External – styles defined in a separate CSS file and linked to one or more pages in a site 

 
<HEAD> 
TITLE>Electronic Portfolio - Home</TITLE> 
<link href="styles.css" rel="stylesheet" type="text/css"> 
</HEAD> 
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Definitions of CSS Styles 
• Class definition – Defines the appearance of the container to which it is assigned. This is 

what a class style would look like: 
 

.content { 
font-size: 2 em; 
margin-right: 0 px; 
margin-left: 0 px; 
margin-top: 0 px; 
margin-bottom: 0 px; 
} 

 
• ID definition– Defines the appearance of a unique container on a page. Apply to things 

that will stand out as different. Used rarely. IDs can only be applied once on a page. 
When would you use an ID? If you want to use Java script to show and hide elements or 
if you set a display to none or to show. Example: A popup menu – needs a unique idea on 
a page. Therefore, you have a piece of Java script that will show the unique ID on the 
page. This is what an ID style would look like: 

 
#navigation{ 
background-color: #000000 
width: 300px; 
border-bottom-width: 1px; 
border-bottom-style: solid; 
border-bottom-color: #014055; 
} 
 
Notice the only major difference is the # instead of the period (.) in front of the style 
name. 

 
• Tag definition – defines the appearance of every instance of a given tag.  

 
 h4{ 

font-family: Verdana, Arial, Helvetica, sans-serif; 
 font-size: 0.85em; 
 font-style: normal; 
 font-weight: bolder; 
 color: #002D62; 

} 
 
Notice in this case, the name of the style changes to the name of the tag. 
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CSS in Dreamweaver: 
 
CSS styles applied to text are reflected in both the CSS Styles panel and the Property inspector. 
Additionally, styles can be applied from either panel, or from the Text menu (Text > Style 
submenu). If you are unable to see the CSS Panel select Window > CSS Styles. This will open 
the panel box on the right of your screen. 
 
The Dreamweaver CSS Styles Panel: 
 
 

 
 
 
 
 
Tag Selector Panel- Relevant CSS 
 
When editing styles do one of the following: 
 

• Right click on the style in the CSS Styles Panel  
 
Or 

 
• Click on the Relevant CSS tab under the Tag 

Panel. 
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Setting Page Properties using the <Body> Tag 
 
The body tag sets the attributes for a page. This means how the page elements will display in a 
browser. 
 
To redefine the <body> tag in Dreamweaver MX 2004, you have two options. You can use the 
Page Properties command or define the style manually using the CSS Styles panel. 
 
The disadvantage of using the Page Properties dialog box to define the style, is the addition of 
the style to the document itself instead an external style sheet.  
 
If the style will only be used in the current document this not a concern, however, if the style will 
be used in repeated styles throughout the Web site, you'll eventually want to put the styles in an 
external style sheet. It may be easier to work locally and then export the styles when you know 
they are properly defined. 
 

Follow these steps to redefine the <body> tag: 

1.  Select Modify > Page Properties or Press the Page Properties button in the Properties Panel 
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2.  Define a default font and font size, and any other attributes desired 
 
Once you defined the page properties the style and its attributes will be displayed in the <Head> 
of the page. 
 

<HEAD> 
 
<TITLE></TITLE> 
 
<style type="text/css"> 
<!-- 
 
body,td,th { 
   color: #FFFFFF; 
} 
 
body { 
   background-color: #000000; 
   margin-left: 0px; 
   margin-top: 0px; 
   margin-right: 0px; 
   margin-bottom: 0px; 
} 
 
--> 
</style> 
 
</HEAD> 

 
3. To see the style definition, open the CSS Styles 
Panel (select Window > CSS Styles) and expand 
the <style> tag. 
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Creating new CSS Styles 
 

To create a new style: 
 

1. Click the New CSS Style button (at the bottom of the 
CSS Styles panel).  

2. In the dialogue box that appears give your style a name 
and define the style as either a Class, and ID, or a Tag.  
In most cases you will define your styles as a Class 
because you will be able to use the style many times on 
the page.  

3. Select either this document only or external style 
sheet. This document only means the style will appear 
in the head of the document while external style sheet 
will place the new style in a style sheet you have 
attached to the document. 
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In the Definition Dialogue box define the attributes for the new style. If the style will use the 
same font style as the Page Properties Body tag you will only need to define other elements. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Applying a Style 
 
To apply the style, simply select the text on the page—or, if the text is by itself in a table cell, 
select the table cell. Using the Property inspector, select the new style (the style you just created) 
from the Style pop-up menu. 
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Removing the <Font> tag or other tags from older Web pages 
 
 

1. Remove the <font> tags from the document by 
selecting Edit > Find and Replace.  

2. In the Find and Replace dialog box, select Specific 
Tag in the Search pop-up menu and choose Font 
from the subsequent pop-up menu to the right. 
Because you are looking for all <font> tags in the 
document, regardless of their attributes, click the 
minus (–) button to remove the attribute criteria.  

3. From the Action pop-up menu, choose Strip Tag and 
then click the Replace All button.  

4. With all of the <font> tags gone, you can now create 
a rule for all the text on the page by modifying the 
body, td, th, rule that Dreamweaver has already 
created. Simply open the Page Properties dialog box 
again. From the Page font list, select the appropriate 
font set.  
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What other attributes should be removed from older Web pages? 

You can use the Dreamweaver Find and Replace command to remove other attributes from your 
document and replace them with CSS styles. Some other attributes that should be removed 
eventually are: 

• <br> tags  
• bgcolor and background attributes  
• align and valign attributes  
• table attributes such as border and cell padding 

 

Exporting document styles to an external style sheet 

Use the following steps to export styles: 

1. Return to the CSS Styles panel and right-click (Control-click on Mac) the style name.  
2. In the context menu, select Export.  
3. An Export Styles dialog box opens, asking you to specify a name for the new style sheet. 

Name the style sheet site.css or any other name you choose and click OK.  
4. Although Dreamweaver exports the styles, they are still in the document. To remove 

them from the document, select the <style> tag in the CSS Styles panel and click the Trash 
icon in the lower right corner of the CSS Styles panel.  

5. To attach a style sheet, click the Attach Style Sheet icon at the bottom of the CSS Styles 
panel and browse to your new external style sheet, site.css.  
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CSS tutorials and samples 

Macromedia’s Developer Center: 

http://www.macromedia.com/devnet/topics/css.html 

 
Official CSS specifications 

World Wide Web Consortium: 

http://www.w3c.org/style 

 


