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Working with Panels 
 
To open Dreamweaver panels select Window on the menu bar, then the panels you would 
like.  
 
Close your panels for more work space select F4. 
 
Using the File Panel 
 
You can access, modify, and save files and folders in your 
Dreamweaver sites, as well as files and folders that are not 
part of a Dreamweaver site. In addition to Dreamweaver 
sites, you can access a server, a local drive, or your desktop.  
 
The Files Panel enables you to view files and folders, 
whether they are associated with a Dreamweaver site or not, 
and perform standard file maintenance operations, such as 
opening and moving files.  
 
Note: In previous versions of Dreamweaver the Files Panel 
was called the Site panel. 
 
To open an existing Dreamweaver site 

• In the Files Panel (Window > Files), select a site from the pop-up menu (where 
the current site, server, or drive appears).  
 

To access a local drive or your desktop 

1. In the Files panel (Window > Files), select Desktop, Local Disk, or CD Drive 
from the pop-up menu (where the current site, server, or drive appears).  
 

2. Navigate to a file, then do any of the following:  
 

o Open files in Dreamweaver or another application  
o Rename files  
o Copy files  
o Delete files  
o Drag files  

When you drag a file from one Dreamweaver site to another or to a folder 
that is not part of a Dreamweaver site, Dreamweaver copies the file to the 
location where you drop it. If you drag a file within the same 
Dreamweaver site, Dreamweaver moves the file to the location where you 
drop it. If you drag a file that is not part of a Dreamweaver site to a folder 



that is not part of a Dreamweaver site, Dreamweaver moves the file to the 
location where you drop it. 

Note: To move a file that Dreamweaver copies by default, hold down the 
Shift key (Windows) or the Command key (Macintosh) while you drag. 
To copy a file that Dreamweaver moves by default, hold the Control key 
(Windows) or the Option key (Macintosh) while you drag. 

To get more information on accessing sites using the Final Panel go to Help on the 
menu bar and select Using Dreamweaver. Search for File Panel. 



Point to File to Add Links 
 
When adding a new link to a file 
with in your site, you should select 
the file from your site panel with the 
Point to file icon to the right of the 
Link box in the Properties Inspector. 
You will see a line appear as you 
move your mouse to the collect file. 
 
 
Changing a link site wide  
 
In addition to having Dreamweaver update links automatically whenever you move or 
rename a file, you can manually change all links (including e-mail, FTP, null, and script 
links) to point somewhere else.  
 
You can use this option at any time (for example, you might have the words "this 
month’s movies" linked to /movies/july.html throughout your site, and on August 1 you 
must change those links to point to /movies/august.html), but it’s particularly useful when 
you want to delete a file that other files link to. 
 
To change a link site wide: 
 

1. Select a file in the Local view of the Files panel.  
 

      Note: If you are changing an e-mail, FTP, null, or script link, you do not need to  
      select a file.  
2. Select Site > Change Link Site wide.  
 
3. The Change Link Site wide dialog box appears. 
 
4. Complete the dialog box.  

 
5. Click OK.  

 
Dreamweaver updates any documents that link to the selected file, making them point to 
the new file, using the path format already used in the document (for example, if the old 
path was document-relative, the new path is also document-relative). The type of the link, 
whether document or root-relative, doesn’t matter. Dreamweaver automatically updates 
the link.  
 
After you change a link site wide, the selected file becomes an orphan (that is, no files on 
your local disk point to it). You can safely delete it without breaking any links in your 
local Dreamweaver site. 
 



Note: Because these changes occur locally, you must manually delete the corresponding 
orphan file in the remote folder and put or check in any files in which links were 
changed; otherwise, visitors to your site won’t be able to see the changes. 
 



Checking for broken, external, and orphaned links 

Use the Check Links feature to search for broken links and unreferenced--also known as 
orphaned--files (files that still exist in the site but no other files in the site link to) in an 
open file, a portion of a local site, or an entire local site.  

The only links that Dreamweaver verifies are links to documents within the site; 
Dreamweaver compiles a list of external links that appear in the selected document or 
documents, but does not verify them. 

To check links within the current document: 

1. Save the file to a location within your local Dreamweaver site.  
2. Select File > Check Page > Check Links.  

The Broken Links report appears in the Link Checker panel (in the Results panel 
group). 

3. In the Link Checker panel, select External Links from the Show pop-up menu to 
view another report.  

The External Links report appears in the Link Checker panel (in the Results panel 
group). 

Tip: You can check for orphaned files when you check links across an entire site. 

4. To save the report, click the Save Report button in the Link Checker panel.  

Note: The target browser report is a temporary file--it will be lost if you don’t 
save it. 

To check links within a portion of a local site: 

1. In the Files panel, select a site from the Current Sites pop-up menu.  
2. In Local view, select the files or folders to check.  
3. Initiate the check by doing one of the following:  

o Right-click (Windows) or Control-click (Macintosh) one of the selected 
files, and then select Check Links > Selected Files/Folders from the 
context menu.  

o Select File > Check Page > Check Links.  

The Broken Links report appears in the Link Checker panel (in the Results panel 
group). 

4. In the Link Checker panel, select External Links from the Show pop-up menu to 
view another report.  



The External Links report appears in the Link Checker panel (in the Results panel 
group). 

Tip: You can check for orphaned files when you check links across an entire site 
(see the next procedure). 

5. To save a report, click the Save Report button in the Link Checker panel.  

To check links in the entire site: 

1. In the Files panel, select a site from the Current Sites pop-up menu.  
2. Select Site > Check Links Sitewide.  

The Broken Links report appears in the Link Checker panel (in the Results panel 
group). 

3. In the Link Checker panel, select External Links or Orphaned Files from the 
Show pop-up menu to view another report.  

A list of files that fit the report type you selected appears in the Link Checker 
panel. 

Note: If you select Orphaned Files as your report type, you can delete orphaned 
files from the Link Checker panel directly by selecting a file from the list and 
pressing the Delete key.  

4. To save a report, click the Save Report button in the Link Checker panel.  

Fixing broken Links:  
 
After you run a links reports, you can fix broken links and image references directly in 
the Link Checker panel, or you can open files from the list and fix links in the Property 
inspector. 
 
To fix links in the Link Checker panel: 
 

1. Run a link check report 
2. In the Broken Links column (not the Files column) of the Link Checker panel (in 

the Results panel group), select the broken link.  
3. A folder icon appears next to the broken link. 
4. Click the folder icon to browse to the correct file to link to, or type the correct 

path and filename.  
5. Press Tab or Enter (Windows) or Return (Macintosh).  
6. If there are other broken references to this same file, a dialog box appears 

prompting you to fix the references in the other files as well. Click Yes to have 
Dreamweaver update all the documents on the list that reference this file. Click 



No to have Dreamweaver update the current reference only. 
 

Note: If Enable File Check In and Check Out is turned on for the site, Dreamweaver 
attempts to check out files that require changes. If it cannot check out a file, 
Dreamweaver displays a warning dialog box and leaves broken references unchanged.  
 
To fix links in the Property inspector: 
 

1. Run a link check report  
In the Link Checker panel (in the Results panel group); double-click an entry in 
the File column.  

2. Dreamweaver opens the document, selects the offending image or link, and 
highlights the path and filename in the Property inspector. (If the Property 
inspector is not visible, select Window > Properties to open it.) 

3. To set a new path and filename in the Property inspector, click the folder icon to 
browse to the correct file, or type over the highlighted text.  

      If you are updating an image reference and the new image appears at the incorrect   
      size, click the W and H labels in the Property inspector or click the Refresh button 
      to reset the height and width values. The W and H labels change from bold to 
      normal type. 
4. Save the file.  

As links are fixed, their entries disappear from the Link Checker list. If an entry still 
appears in the list after you enter a new path or filename in the Link Checker(or after you 
save changes in the Property inspector), it means that Dreamweaver cannot find the new 
file and still considers the Link broken. 



Checking for browser compatibility 
 
Dreamweaver enables you to create web pages with elements that are supported by all 
major graphical browsers (such as images and text), as well as with elements that are 
supported only by newer browsers (such as CSS styles).  
 
You should determine who the audience for your site is likely to be, and what browsers 
they’re likely to use. If most of your users will be using Netscape 4 (as is still true in 
some academic intranet environments, for example), you should avoid using tags that 
aren’t supported in that browser. 
 
The Check Target Browsers feature tests the code in your documents to see if any of the 
tags, attributes, CSS properties, or CSS values are unsupported by your target browsers. 
The check does not alter the document in any way. 
 
The target browser check gives information about three levels of potential problems: 
errors, warnings, and informational messages. The following descriptions explain the 
differences between those levels: 
 

• An error indicates code that may cause a serious visible problem in a particular 
browser, such as causing parts of a page to disappear. (In some cases, code with 
an unknown effect is also marked as an error.)  

• A warning indicates a piece of code that won’t be displayed correctly in a 
particular browser, but that won’t cause any serious display problems.  

• An informational message indicates code that isn’t supported in a particular 
browser, but that has no visible effect; for example, the img tag’s galleryimg 
attribute isn’t supported in some browsers, but those browsers ignore that 
attribute, so it has no visible effect.  
 

By default, Dreamweaver automatically performs a target browser check whenever you 
open a document. You can also run a target browser check manually on a document, on a 
folder, or on an entire site. 
 
Note: The target browser check is not updated continually. After you make changes to 
code, run the target browser check manually to confirm that you’ve eliminated code that 
doesn’t work with your target browsers. 
 
The target browser check does not check scripts in your site. Also, the target browser 
check is not a syntax validator; it detects only markup that isn’t supported in your target 
browsers. 
 
Note: The Check Target Browsers feature uses text files called browser profiles to 
determine which tags particular browsers support. Dreamweaver includes predefined 
profiles for Netscape Navigator version 3.0 and later, for Microsoft Internet Explorer 
version 3.0 and later, and Opera version 2.1 and later. For information on how to modify 
the existing profiles or to create new ones, see the "Customizing Dreamweaver" article at 



the Dreamweaver Support Center.  
 
To select browsers for Dreamweaver to check against: 
 

1. Select Settings from the Target  
Browser Check menu in the Document toolbar.  

      The Check Target Browsers dialog box appears. 
2. Select the checkbox next to each browser you want to check.  
3. For each selected browser, select a minimum version to check against from the 

corresponding pop-up menu.  
 

      For example, to verify that all of the document’s markup is supported in  
      Microsoft Internet Explorer 3.0 and later and Netscape Navigator 4.0 and later,    
      select the checkboxes next to those browser names, and select 3.0 from the 
      Microsoft Internet Explorer pop-up menu and 4.0 from the Netscape Navigator    
      pop-up menu. 
 

To view the results of an automatic target browser check, do one 
of the following: 
 

• Open a file and view the file in Code view (View > Code or View > Code and 
Design).  

• After making a change in Code view, click the Refresh button in the Property 
inspector or press F5.  
 

A wavy red underline appears under the name of every item that’s considered an error in 
one of your target browsers. (Warnings and informational messages are not marked in 
Code view; to view warnings and informational messages, view the report for the entire 
document.) If Dreamweaver finds no unsupported markup, then nothing is underlined, 
and the Target Browser Check menu icon in the Document toolbar changes to indicate 
that there are no errors. 
 
Tip: To easily use various commands related to target browser checks, select a command 
from the context menu by right-clicking (Windows) or Control-clicking (Macintosh) any 
red-underlined item. 
 
To see which browsers don’t support a specific red-underlined 
item: 

• Position the pointer to point to the red-underlined text.  
 

A tooltip appears, indicating which browsers don’t support that item. 
 
To view the Check Target Browser report for the entire 
document: 
 



• In the Target Browser Check menu in the Document toolbar, select Show All 
Error.  

 
The Results panel group appears, with the Target Browser Check panel selected. Errors 
are marked with a red exclamation mark icon, warnings are marked with a yellow 
exclamation mark icon, and informational messages are marked with a word-balloon 
icon. 

To view a long error message in the Target Browser Check panel: 
 

1. Open the Target Browser Check panel.  
2. Select an error message that’s too long to read in the panel.  
3. Click the More Info button.  

 
A Description dialog box appears, displaying the full text of the selected error message. 
 

To disable the automatic target browser check: 
• Deselect Auto-Check On Open from the Target Browser Check menu in the 

Document toolbar.  
 

To jump to the next or previous error  in the code: 
• Select Next Error or Previous Error from the Target Browser Check menu in the 

Document toolbar.  
 

To jump to a specific error from the Target Browser Check panel: 
 

• Double-click the error message.  
 
The unsupported markup is selected in Code view. 
 

To run a target browser check manually on the current file: 
 

• Select File > Check Page > Check Target Browsers.  
 
The report appears in the Target Browser Check panel (in the Results panel group).  
 

To run a target browser check manually on a site or a set of selected files: 
 

1. In the Local view of the Files panel, select a set of files, or select the folder that 
contains the entire site.  

 



2. Select File > Check Page > Check Target Browsers.  
      The report appears in the Target Browser Check panel (in the Results panel  
      group).  
 
3. To cancel the report while it’s running, click the Stop button in the Target 

Browser Check panel.  
 

To switch between viewing the current document report and viewing the full site 
report: 
 

• In the Target Browser Check panel, select Current Document or Site Report from 
the pop-up menu.  
 

To save a target browser check report: 
 

• Click the Save Report button in the Target Browser Check panel.  
 

Note: The target browser check report is not saved automatically; if you want to keep a 
copy for future reference, save it. 
 

To view a target browser check report in a browser: 
 

• Click the Browse Report button in the Target Browser Check panel.  

To fix an error: 
 

• Remove the unsupported code, or change it to other code that’s supported by your 
target browsers.  
 

To specify that Dreamweaver should ignore a particular type of error: 
 

• Right-click (Windows) or Control-click (Macintosh) red-underlined code, and 
select Ignore Error from the context menu.  
 

That type of error is changed to a warning, and Dreamweaver stops underlining that type 
of error in all documents. 
 



Creating a Web photo album 
 
Creating a photo album to display your photos on your Web site is very easy. Have all of 
your photos in one location. To create your photo album: 
 

1. Open a new HTML page in Dreamweaver.  
2. Select Command from the menu bar.  
3. In the dropdown menu give your album a title, a sub heading if you would like.  
4. Browse for the Source images folder.  
5. Select the destination folder for your album.  

Choose the display size for your photo album images.  
Choose how many columns you would like the pictures to be displayed in.  
Choose the quality for your pictures. This includes the Thumbnail and photo 
format. JPEG-better quality is best for displaying pictures.  

6. Select Ok. 
 
 
Import Text from Microsoft Word  
 
Importing text from Microsoft Word adds a lot extra coding and other information that is 
not needed. There is a great feature in Dreamweaver allows users to import and easily 
clean up pages from Microsoft Word. This lets you keep the formatting from a Word 
document, without having to tweak the code by hand.  
 

1. Begin by saving the Word document as an HTML page.  
2. In Dreamweaver, select File 
3. Select Import 
4. Select Import Word HTML.  
5. After you've selected the file, a window appears that lets you choose what tags to   
6. clean up.  

  
 



Adding Behaviors 
 
"Behavior" is a Dreamweaver term for JavaScript codes that can easily be built into a 
document. Macromedia defines "behavior" as "a combination of an event and an action."  
 
Swapping an Image  
We'll start with a basic and popular behavior, swapping an image. Anytime a user mouses 
over a menu item and that item becomes highlighted, that's an image swap.  

To begin, you'll need the two graphics you plan to work with. Make sure they have the 
same dimensions. Insert the first graphic into your page and look at its properties in the 
Properties window. You'll need to assign it a name. The field for this is in the upper left. 
Any brief name will do.  

While you have the image selected, move to the Behaviors window. Click on the "+" 
button, which means add a behavior. Choose Swap Image. The name you gave the first 
image will be in the upper field. In the lower, browse your directory for the second 
image. Hit okay and you're done.  

Adding New Behaviors  

Dreamweaver is made to be easily extended. If you're proficient at writing JavaScript, 
you can create your own behaviors for commonly used actions. But you don't need to 
write JavaScript. To download new behaviors, go to the Behaviors menu in the Tag 
Selector Panel, and click the "+" sign. At the bottom on the menu, you'll see "Get More 
Behaviors& " Click this for the latest offerings from Macromedia and thoughtful users 
around the globe. As of this writing, there weren't any new behaviors for Dreamweaver 3, 
but there were plenty for Dreamweaver 2.  

 

 

 

 


